How NOT to execute a phrase after comma

User-to-User discussion about the PhraseExpress macro programming.
Post Reply
SoftCollector
Posts: 2
Joined: 24 Sep 11, 23:09

How NOT to execute a phrase after comma

Post by SoftCollector » 19 Nov 22, 08:51

Dear all,

I am not sure how to set a phrase NOT to be executed if preceded by a certain character, in this case a comma.

So, to explain again, the phrase is:

, само да

and it is triggered by

само да

...in other words, it introduces a comma if a comma was incorrectly omitted before the phrase (which also includes a white space), but IF the comma was correctly included, then the result would be

,, само да

I want to make sure that the phrase is not triggered if a comma is already present. I am not sure how to do that.

Best regards,
SC

Technical Support
Posts: 3343
Joined: 10 Feb 06, 22:23

Post by Technical Support » 21 Nov 22, 09:45

One solution is to set the autotext to " само да" and in the "Expert options" set Prefix to Custom and list all characters that can be before the autotext.
The other solution would be using RegEx autotext.

SoftCollector
Posts: 2
Joined: 24 Sep 11, 23:09

Post by SoftCollector » 23 Dec 22, 21:23

Dear Support,

Would it be possible to include in future versions the option for "all characters with the exception of [this one]"?

Best regards,
SC

Post Reply